三好技巧网

cisco 2500路由器通过ADSL上网的配置方法步骤

时间:2010-08-05 07:28来源:enet 作者:admin 点击:

  本例要接入的是北京电信adsl pppoe,需要使用一个普通adsl modem和一台cisco 2500路由器(双以太口),ios12.2(15)t,能够实现局域网共享上网。

  配置步骤共为7步:

  第一步:配置vpdn

  vpdn enable # 启用路由器的虚拟专用拨号网络---vpnd

  vpdn-group office # 建立一个vpdn组

  request-dialin # 初始化一个vpnd tunnel,建立一个请求拨入的vpdn子组

  protocol pppoe # vpdn子组使用pppoe建立会话隧道

  第二步: 配置路由器连接adsl modem的接口

  interface ethernet1

  no ip address

  pppoe enable # 允许以太接口运行pppoe

  pppoe-client dial-pool-number 1 # 将以太接口的pppoe拨号客户端加入拨号池1

  第三步:配置逻辑拨号接口:

  interface dialer1

  ip address negotiated # 从adsl服务商动态协商得到ip地址

  ip nat outside # 为该接口启用nat

  encapsulation ppp # 为该接口封装ppp协议

  dialer pool 1 # 该接口使用1号拨号池进行拨号

  ppp authentication pap callin # 启用ppp pap验证

  ppp pap sent-username xxxxxxx password 0 yyyyyyy # 使用已经申请的用户名和口令

  第四步:配置内部网络接口

  interface ethernet0(内部网络接口)

  ip address 10.1.1.1 255.255.255.0

  ip nat inside # 为该接口启用nat

  第五步:配置路由器为内部网络主机提供dhcp服务

  ip dhcp excluded-address 10.1.1.1

  ip dhcp pool abc

  import all(导入dns和wins server)

  network 10.1.1.0 255.255.255.0

  default-router 10.1.1.1

  第六步:配置nat:

  access-list 1 permit 10.1.1.0 0.0.0.255

  ip nat inside source list 1 interface dialer1 overload

  第七步:配置缺省路由

  ip route 0.0.0.0 0.0.0.0 dialer1

顶一下
(0)
0%
踩一下
(0)
0%

------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
验证码:点击我更换图片
栏目列表
推荐技巧
无觅相关文章插件,快速提升流量